Thread: United Coders
View Single Post
Old 03-13-2004, 09:54 AM   #16
erdos
 
Posts: n/a
Coder #56: hey guys, how's this for a first line?
[code] while ( TRUE ) update( );[/quote]

Coder #104: whoah, did they start a whitespace ration? Make it
[code] while ( TRUE )
    update( );[/quote]

Coder #37: update is too generic, it could easily conflict... let's make it
[code] while ( TRUE )
    update_MUD( );[/quote]

Coder #194: Wouldn't it be more elegant to do this?
[code] while ( update_MUD( ) )
   ;[/quote]

Coder #562: I think it'd be more readable if we did this:
[code] #define CONTINUE_MUD 1
#define STOP_MUD 2
...
while ( update_MUD( ) != STOP_MUD )
   ;[/quote]

Coder #62: Argh, the last thing we need is redundant and pointless definitions!! Anyway, we can just use exit() from the lower level functions, so I say we just do
[code] for (;; )
    update_MUD( );[/quote]

Coder #11: My "microsoft vbasic 101" teacher said if you use capital letters in a function name it makes baby jesus cry! Make it
[code] for (;; )
    update_mud( );[/quote]

Coder #73: This is purely aesthetic, but I prefer
[code] for (;; )
    update_mud ();[/quote]

Coder #99: Since this is open source, we need more comments. A better version would be
[code] for (;; ) /* Infinite loop */
    update_mud (); /* basic pulse of the mud */[/quote]

Coder #29: No, no, no, that's ugly! Make it
[code] for (;; )                   /*
    update_mud ();     *  Main game loop
                                *    -Coder 29, March 14 2004
                               */[/quote]

Coder #57: Whoah, whoah, are you trying to steal all the credit for these lines?! Freaking creep. I prefer this:
[code] /*                       *\
*     Main Loop    *
\*                       */
for (;; )
    update_mud();[/quote]

Coder #84: Guys! Guys! I've got it! This is perfect:
[code] while ( TRUE ) update( );[/quote]

(Return to top of message and re-read from beginning)
  Reply With Quote